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Chapter 1  Introduction

Allworx OfficeSafe™ is a PC application that performs Allworx server backups and restores. The 
OfficeSafe application includes an administration tool to configure the Windows server and server 
restores, as well as manage the server backups. The OfficeSafe application is capable of doing 
backups of individual customer systems interactively and provide an ongoing server backups to 
multiple customers.

1.1 Who Should Read this Guide
This guide is for Allworx administrators that:

• install and maintain Allworx servers.

• understand computer networking and basic telephony.

• completed the Allworx Partner technical training. 

1.2 Equipment Requirements
The table below is a complete list of equipment and requirements necessary to perform all operations 
identified in this Operations Guide. Each chapter has a specific list of equipment and requirements 
necessary to perform the operations identified with that chapter. 

Equipment Requirements

PC •  Running OS (with latest service pack)

•  RAM minimum: 2 GB 
•  Monitor resolution: 1024 x 768 (XGA)
•  OfficeSafe PC application
•  Internet connection 
•  Windows Administrator Privileges
•  Windows Firewall configuration must enable the OfficeSafe application to perform backups
•  Obtain the IP address automatically.

Allworx server •  System Software 7.0 (minimum)*
•  Administration permissions and passwords for each Allworx server.
•  IP Address or DNS name of each Allworx server.
* NOTE: System Software 8.0 requires OfficeSafe version 8.0 (minimum).

Allworx System 
Installation Guide

The guide specific to the Allworx server model that describes the mounting, electrical connections, 
and input/output accessories of the Allworx Server. This guide is available at: https://
allworxportal.com/

Allworx Server 
Administrator’s Guide

The guide is specific to the Allworx System Software setup and configuration of the Allworx Server. 
This guide is available at: https://allworxportal.com/

•  Windows 7 32-bit SP1 •  Windows 8 64-bit •  Windows 10 32-bit

•  Windows 7 64-bit SP1 •  Windows 8.1 32-bit •  Windows 10 64-bit

•  Windows 8 32-bit •  Windows 8.1 64-bit
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1.3 Backup/Restore Overview
Each Allworx server backup is a system image. The Allworx server initiates the backup and transmits 
the information over the network to the PC running the OfficeSafe application. Allworx administrators 
should plan backups for:

• Newly-installed systems, as soon as the configuration is complete. This enables users to 
re-establish the site configuration easily. 

• Regularly scheduled backups.
• After making changes to the Allworx server configuration.
• Prior to installing Allworx software upgrades. 
Do restores on-site using the OfficeSafe application loaded on a service PC, as necessary. If the 
preferred backup is not in the service PC OfficeSafe database (i.e. the service PC did not do the 
backup), copy the backup onto the service PC, anywhere on the file system.

1.4 Full and Incremental Backups
Allworx administrators can determine the type of backup to perform. The backup configurations on the 
Allworx server include a Mode setting for full or incremental backups. 

The collection of full and subsequent incremental backups requires extra disk space and can become 
cumbersome to manage. The OfficeSafe application has the ability to override the server Mode setting 
and force doing a full backup under certain conditions such as the passage of time or after saving of a 
certain number of incremental backups. See the “Configuration” on page 8 for information on 
configuring these settings.

1.5 Mapped Network Drives
Allworx administrators may select disk drives on other network servers mapped on the PC within the 
Windows account as the destinations for backups. When selecting a network drive, the Allworx 
administrator must provide the necessary credentials for the drive to enable storing backups on the 
network drive even when there are no privileged users logged into the PC.

Mode Setting Description

Full Backup Includes a copy of all server data, such as:
•  operating system
•  software load
•  system configurations
•  user voicemails
NOTE: The number and length of voicemails on the system affects the size of the backup files and can take 
a long time to transmit to the OfficeSafe PC.

Incremental Backup •  Performs a full backup the first time, and then performs smaller, faster backups.
•  Includes only changed data since the last backup, such as new voicemails and call details records.
•  Normally much smaller than full backups and take less time to transmit.
•  Recommended server Mode setting. (If doing regularly scheduled, incremental backups, it is best practice 

to do a full backup periodically.
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1.6 Compatibility
The compatibility requirements of the OfficeSafe application include:

• Multiple versions of OfficeSafe 6 and later cannot reside on a PC at the same time. Uninstall the 
previous OfficeSafe version before installing the latest version of OfficeSafe.

• OfficeSafe 6 or later can reside on a PC at the same time as OfficeSafe 5 or lower. 

• OfficeSafe 5 or lower cannot do backups until stopping the OfficeSafe 6 or later Windows 
service. 

• OfficeSafe 6 and later are not compatible with backups made using OfficeSafe 5 or lower. Users 
cannot import or restore OfficeSafe 5 backups into OfficeSafe 6 or later. 

Allworx recommends installing the OfficeSafe application on all PCs and using it for all backups. For 
PCs with OfficeSafe 7 or lower applications doing backups:

1. Keep the OfficeSafe 7 application on the PC. 

2. Backup the Allworx Servers with the newer OfficeSafe application.

3. Remove the older OfficeSafe application version and older backups from the PC. Do not 
remove the OfficeSafe 7 or lower application until all OfficeSafe backups are complete.
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Chapter 2  Installation and Configuration

Install the OfficeSafe application using one of the following options:

• Every PC used for Allworx server installation and support.

• A Windows-based server at a central location to do backups of Allworx servers on multiple 
sites. The central server must have a network communications path to all servers identified for 
backup such as over the Internet or VPN. 

Allworx servers include the ability to configure and schedule automatic backups at various 
frequencies. If the upgrade is from an earlier version of the OfficeSafe 6 or later, uninstall the current 
OfficeSafe application from within the Control Panel. It is not necessary to uninstall the OfficeSafe 5 or 
lower application.

2.1 Installation Checklist
Follow the order of the steps for a successful installation. Click the link in the Installation Guide Link 
column for more detailed information. 

2.2 Installation
The Windows Server 2008 R2 operating system requires .NET Framework 3.5.1 prior to installing the 
OfficeSafe application. 

Note: If upgrading from an earlier version of the OfficeSafe 6 or later (requiring a removal of the earlier version), the application 
retains configuration information and it is unchanged. In addition, no backup information is lost.

Step Description Installation Guide Link

.NET Framework

1 Install the .NET Framework on the Windows PC. For more detailed information, see “Install the 
.NET Framework” on page 6.2 Install the .NET Framework on the Windows server.

Install the OfficeSafe Application

3 Download the OfficeSafe application. For more detailed information, see “Install the 
OfficeSafe Application” on page 7.4 Launch the setup.exe file and follow the screen prompts.

5 Select a folder to store the backups. 

6 Click Close to finish the installation process.

7 Configure the Windows firewall, if necessary. For more detailed information, see “Enable the 
OfficeSafe Application through the Windows 
Firewall” on page 8.
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2.2.1 Install the .NET Framework

To install the .NET Framework version 3.5 SP1 installer on the Windows 7 or Windows 8 
operating system:
1. Navigate to the computer Start Menu > Control Panel. Verify the view is the Classic view, and 

click the Programs and Features icon.

2.  Click Turn Windows Features on or off (located in the left column). Windows 7, and Windows 
8 operating systems have User Account Control. Accept to proceed.

3. Select the .NET Framework 3.5 (includes .NET 2.0 and 3.0) installer and click OK the install 
begins. Click Download files from Windows Update. The install completes. 

To install the .NET Framework 3.5.1 on Windows Server 2008 (32-bit and 64-bit versions) and 
Windows 2008 R2:
1. Navigate to the computer Server Manager > Add Features > .NET Framework 3.5.1. 

2. Select the .NET Framework 3.5 (includes .NET 2.0 and 3.0) installer and click OK the install 
begins. Click Download files from Windows Update. The install completes. 

To install the .NET Framework 3.5.1 on Windows Server 2012 (32-bit and 64-bit versions) and 
Windows 2012 R2:
1. Navigate to the computer Server Manager > Manage > Add Roles and Features. The dialog 

box opens.

2. Click Next and verify the Role-based or feature-based installation selection. Click Next.

3. Navigate to Select a server from the server pool > Next > .NET Framework 3.5 Features. 
Click Next and follow the on-screen prompts. 
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2.2.2 Install the OfficeSafe Application

1. Download the OfficeSafe application zip file from the Allworx Partner Portal and unzip the file to 
a folder on a PC. 

2. Double-click the setup.exe file and follow the screen prompts. 

3. Select a folder to store the backups. Accept the default (C:\backup) or select another folder on a 
drive that has enough space for the backups.

4. Click Close to finish the installation process.

The setup program installs a Windows service that does the backups. Important notes:

• The service starts automatically after installation. 

• The OfficeSafe Administration Tool application installs and places an icon to open it on the 
desktop. 

• Use the Allworx web administration tool to:

• configure the backup / restore settings.

•  manage the stored Allworx server backups on the PC (described later in this document).

If running firewall software on the PC, configure the PC to enable backups. Procedures for enabling 
backups through the Windows Firewall are provided below. 

• If using a third-party firewall program, use the appropriate procedures for the product. 

• If connecting the PC through a hardware firewall, route the OfficeSafe port (the default is 5001) 
through the firewall to the OfficeSafe PC.

Note: A user with Windows Administrator rights must install the OfficeSafe application.
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2.2.3 Enable the OfficeSafe Application through the Windows Firewall

To enable the OfficeSafe application through the Windows Firewall - Windows 7 and Windows 
Server 2008:
This procedure requires Administrator privileges.

1. Open the Windows Control Panel.

2. Click Windows Firewall. If the Windows Firewall does not display in the Control Panel window, 
navigate to System and Security > Windows Firewall.

3. Click Allow a program or feature through Windows Firewall. A list of programs displays. 
Click Allow another program. The Add a Program window displays.

Windows 7: If there is a prior version of the OfficeSafe application installed on this PC, the 
OfficeSafe application may display in the Programs list. Ignore this. If OfficeSafeService.exe 
does not display not in the list, click the Change settings button. 

4. Click Browse in the Add a Program window.

5. Navigate to My Computer > C: > Program Files > Allworx > OfficeSafe Service (Not 
OfficeSafe but OfficeSafe Service). 

Windows 7: If the Windows operating system is the 64-bit version, navigate to Program Files 
(x86) rather than Program Files.

6. Click OfficeSafeService.exe, and then click Open. The Browser window closes.

7. Locate OfficeSafeService.exe in the Programs list, and then click Add. The Add window 
closes. OfficeSafeService.exe displays in the Allowed programs window and its box is checked. 
Click all unchecked buttons on the same row as OfficeSafeService.exe, and then click OK.

2.3 Configuration
Prior to using the Allworx web administration tool to manage backups, ensure the Allworx 
administrators have Read and Write access to the Backup Folder containing the stored Allworx server 
backups. Any Allworx administrator changing the OfficeSafe configuration must have Windows 
Administrator permissions.

To access the configuration options:
1. Launch Allworx web administration tool and log in with the Allworx username and password. 

After the application synchronizes with the OfficeSafe application, the main window displays 
any stored backups in the OfficeSafe backup repository.
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2. Click Tools > Options. The Backup Options tab displays. There are two sub-tabs. 

• Default backup setting

• Server-specific settings.

2.3.1 Default Backup Settings Tab
The settings on the Defaults sub-tab applies to the first backup of new servers and to any selected 
existing servers.

Option Description

Backup Repository This is the main storage directory for all OfficeSafe backups. The OfficeSafe application creates a backup 
sub-folder for each server. 
•  If changing the Backup Repository folder, the application saves all subsequent backups of new and 

existing servers using the default settings in the new folder. 
•  If configuring the Backup Repository on a network drive, the Windows Administrator must enter the 

required Credentials (Domain, User Name, and Password) for accessing the drive. See “To configure the 
credentials:” on page 12 for more information.

NOTE: If there is a check in the Move backups using defaults to a new repository box, changing the 
repository location to or from a network drive could take several minutes, depending on the amount of data 
and the speed of the network. 
NOTE: If a using network folder to store backups, the network folder may display in a format that includes 
the server address where the folder resides. This is not necessarily a problem. It can be the result of two 
possible issues: (1) The Windows account does not have a drive mapping for the network folder or (2) the 
Windows Administrator does not have sufficient access rights to the folder. In either case, users cannot 
manage the backups stored on the network drive. The application continues to store backups into the folder 
successfully, if the network drive credentials are still valid.

Move backups using 
defaults to a new 
repository

•  Check the box to move previously stored backups to the new location.
•  If changing the Backup Repository folder and this box is left unchecked, the application stores the new 

backups in the new location, but any previously-stored backups remain in the previous directory. 

NOTE: Changing the repository location to or from a network drive could take several minutes depending on 
the amount of data and the speed of the network. 
NOTE: If the user does not have write permissions for both source and destination folders, it is not be 
possible to move the existing backups. The ‘Move backups’ checkbox is not available.

Overrides for Full Backup The recommended setup for the server backup Mode is Incremental:
•  the first backup made for the server is a full backup.
•  all subsequent backups are incremental backups. 
•  The OfficeSafe application overrides the Incremental backup setting by forcing a full backup, based on the 

selected condition.

Previous Backup Sets 
Retained

Whenever doing a full backup, the application creates a new Backup Set. The Backup Set contains the full 
backup along with all subsequent incremental backups for that server. Select the number of prior backup 
sets to retain in the OfficeSafe backup database.

Notify Settings: Recipient 
Group

Users may configure the OfficeSafe application to send an email indicating the status of backup operations 
as completed. A Recipient Group is a collection of email addresses to send notifications. Define the 
Recipient Groups on the Notification options tab. To send a notification, select a group from the list of 
defined groups.
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2.3.2 Server-specific Backup Settings

2.3.3 Restore Options
Use an on-site service PC loaded with the OfficeSafe application to do a restore, as needed. If using a 
dedicated backup PC for backups, copy the preferred backup file to the on-site service PC.

The Restore options enable users to select which backup to use for restore of an Allworx server. From 

Option Description

Named Server Servers with complete backups display in the Named Server list. Click a server to view and modify the 
settings for subsequent backups of that server

Rename Change the servers with completed backups displayed name. 
•  It may be convenient to change the server name to the customer site name. 
•  Users have the option to rename the folder for the server backups to match the new server name. 
•  The server folder is in the main backup folder and stores the backups for the selected server.

Folder Storage folder for the selected server backups. 
•  If changing the folder, previously stored backups move to the new folder and the application saves all 

subsequent backups. 
•  If configuring the Backup Repository on a network drive, the Windows Administrator must enter the 

required Credentials (Domain, User Name, and Password) for accessing the drive. See “To configure the 
credentials:” on page 12 for more information.

NOTE: Changing the repository location to or from a network drive could take several minutes depending on 
the amount of data and the speed of the network. 
NOTE: If a using network folder to store backups, the network folder may display in a format that includes 
the server address where the folder resides. This is not necessarily a problem. It can be the result of two 
possible issues: 
1.  The Windows account does not have a drive mapping for the network folder.
2.  The Windows Administrator does not have sufficient access rights to the folder. 
In either case, users cannot manage the backups stored on the network drive. The application continues to 
store backups into the folder successfully, if the network drive credentials are still valid.

Overrides for Full Backup Recommended setup for the server backup Mode is Incremental, which is the first server backup is a full 
backup but all subsequent backups are incremental backups. The OfficeSafe application overrides the 
Incremental backup setting by forcing a full backup, based on the selected condition.

Previous Backup Sets 
Retained

Creates a new backup set whenever a doing full backup. The Backup Set contains the full backup along 
with all subsequent server incremental backups. Select the number of prior backup sets to retain in the 
OfficeSafe backup database.

Notify Settings: Recipient 
Group

Configure the OfficeSafe application to send an email indicating the status of backup operations as 
completed. A Recipient Group is a collection of email addresses to send notifications. Define the Recipient 
Groups on the Notification options tab. To send a notification, select a group from the list of defined groups.

Set Defaults Open a window to configure this or all existing servers to use default Backup and/or Notification settings. 
Once configured this way, the server or servers use the default settings until Set Defaults options are 
changed.
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the main window, click View > Options. Click the Restore tab. The Restore Options tab displays.

2.3.4 Network Options
The Administrator can receive backups on any network interface configured on the PC, including 
VPNs. Use the Network Options tab for setting the port number and adjusting the maximum number 
of simultaneous connections for backups. 

To view or modify the Network options, click Tools > Options > Network. 

Windows 7 Note: Even when installing with Administrator permissions, the options to Start, Stop and 
Restart the Backup Service may remain disabled. 

To configure Administrator permissions:
1. Navigate to My Computer > C: > Program Files > Allworx > OfficeSafe Service. If the 

Windows 7 operating system is the 64-bit version, navigate to Program Files (x86) rather than 
Program Files. 

Option Description

Most Recent Backup Use the most recent backup in the OfficeSafe database for the server being restored. If the application does 
not find any backups for this server, the restore fails.

Named Server Use a backup from a different server that in the OfficeSafe database. This is useful when switching servers. 
The Allworx Server Administrator can load the original server configuration onto the replacement server.

NOTE: When backing up from a different server, the application does not restore the original server feature 
keys or activate the features on the new server. The Allworx Server Administrator must obtain feature keys 
specifically created for the new Allworx server. 

Select Backup File Use this option if the backup file is not in the OfficeSafe database on the service PC. This is often the case 
when doing backups on a dedicated, backup PC but the administrator is using a different PC (e.g. a service 
laptop) to do the restore. Therefore, copy the file from the dedicated backup PC to the service laptop. 
Choosing Select Backup file enables users to browse the file system of the laptop to select the copied 
backup file.

Option Description

Maximum Allowed 
Connections

Controls the number of backups happening at one time. The value can be set to a maximum of 10. If 
simultaneous backups are using too much network bandwidth, decrease the value.

Connection Port Default port (5001) for both the OfficeSafe application and Allworx servers. Users may select a different 
port, if required. Verify the OfficeSafe application and all of the Allworx servers identified for backup are set 
to the same port number. If changing the Connection Port, restart the OfficeSafe service. From the Main 
Window, click Tools > Backup Service > Restart. It may take up to two minutes for the restart to complete.

Active Network Interfaces IP Address and description of each active network interface on the PC displays. If connecting to the 
customer’s site using a VPN, connect to the VPN, and then verify that the VPN IP Address is in the Active 
Network Interfaces list. If not, check the VPN interface.

NOTE: Only users with Administrator permissions on the PC can restart the service.
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2. Right-click the OfficeSafeAdmin.exe file, and click the Create shortcut option. The Windows 7 
operating system indicates that a direct shortcut creation is not possible and asks to place it on 
the desktop instead. Click Yes.

3. Right-click the newly-created shortcut on the desktop and select Properties.

4. Locate the Shortcut tab and click Advanced… The Advanced Properties dialog box displays. 
Check the Run as Administrator checkbox, and then click OK.

5. Click the General tab and modify the shortcut title to indicate that this shortcut has 
Administrator privileges. Click OK.

6. Click OK to accept the configuration selection.

7. Double-click on this new shortcut and navigate to Tools > Backup Service from within the 
application. Depending on the state of the OfficeSafe service, one or two of the options should 
be available.

To configure the credentials:
When selecting a network drive for storing backups, the user:

1. Enters credentials (Domain, User Name, and Password) to access the drive. 

2. Navigate to Tools > Options > Credentials to view and manage the credentials. 

To configure the notifications:
Users can configure the OfficeSafe application to provide automatic notification emails for backup 
successes, failures, or both. Users can setup the notifications for specific servers or for all servers. 

Navigate to Tools > Options > Notification > New… The Notification Configuration window displays. 

Option Description

Delete Only available if the selected Credential is not in use within any backup configuration. If the Credentials are 
in use, an asterisk (*) displays in the In Use column.

Modify Change the existing Credentials. This is necessary if the password for the user to access the network drive 
has changed.

Setting Description

Recipient Group Enter a descriptive name.

Used By Identify which server backup configurations use the notification setup.

Notify On Select when to notify: backup passes, fails, or both.

SMTP Server Enter the DNS name or IP address of the mail server using this notification. The email account provider 
should supply this information.
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2.3.5 Troubleshooting Notifications
If the recipients are not receiving notifications, there may be a problem with the network, the email 
server, or both. Check if the PC is queuing notification emails. Navigate to View > Notify Queue. The 
Notification Queue table displays.

This window displays any notifications that the OfficeSafe application was unable to send the 
notification. Users can also set the Retry Interval and the Maximum Life. After a notification exceeds 
the Maximum Life setting, the application no longer retries to send the notification and deletes it. 
Entering a zero for Maximum Life causes the application to delete unsuccessful emails immediately.

If notification emails are stuck in the queue, check the email server setup in the Notification Options or 
contact your Allworx Server Administrator.

Port Enter the Port number for the SMTP Server. The email account provider should supply this information.

Use Authentication Check this box and enter the User Name and Password, if the SMTP Server requires authentication. The 
email account provider should supply this information.

Secure Connection Select the SMTP server security protocol, if any. The email account provider should supply this information.

Sender’s Email (from) Enter the account email address on the SMTP Server.

To, CC, Bcc Enter email addresses for the intended recipients of the notification

Test Email After entering the required information, click Test Email to verify that the notification is set up properly. The 
application sends a test email to the configured recipients. Verify all recipients received the email prior to 
using this Notification setup for backup notifications.

Setting Description
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Chapter 3  Backing up Allworx Servers

This chapter describes the steps necessary to perform an Allworx server backup using the OfficeSafe 
application.

3.1 Backup Checklist
Follow the order of the steps for a successful backup. Click the link in the Installation Guide Link 
column for more detailed information. 

3.2 Setting up the Allworx server and OfficeSafe PC

To setup the OfficeSafe PC:
1. Connect the OfficeSafe PC to the customer network or ensure there is a connection to the 

server over the Internet to the site. 

If a VPN is necessary to connect to the customer network, log into the VPN.

2. Navigate to Tools > Options > Network tab. 

3. Verify the IP address of the OfficeSafe PC connection to the customer network is present in the 
Active Network Interfaces list. Click OK to close the window.

To setup the Allworx Server:
1. Log into the Allworx administration web page. 

2. Navigate to Maintenance > Backup > Modify.

Step Description Installation Guide Link

1 Setup the OfficeSafe PC. For more detailed information, see “To setup the OfficeSafe PC:” 
on page 15.

2 Setup the Allworx server. For more detailed information, see “To setup the Allworx Server:” 
on page 15.

3 (Optional) Setup a PC at the customer site. For more detailed information, see “To setup an OfficeSafe PC at 
the customer site:” on page 16.

4 Perform the backup. For more detailed information, see “Initiate a Backup” on page 16.

5 Manage the backup files. For more detailed information, see “Manage the Backup Files” on 
page 16.
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3. Set the IP Address and TCP/IP Port to the public IP address and port number of the PC running 
the OfficeSafe application. If the PC is behind a router, verify the port is forwarded to the backup 
PC. You can find the IP address and port number at OfficeSafe Tools > Network Options tab.

4. Click Update.

To setup an OfficeSafe PC at the customer site:
A PC can be set up at the customer site to capture backups on a regular basis. Configure a PC 
described in “To setup the OfficeSafe PC:” on page 15. 

1. Verify the PC has sufficient disk space to store a number of backups. 

2. Log in to the Server Admin page and navigate to Maintenance > Backup > Modify. 

3. Select the IP Address of the PC, the port number to use, the backup frequency and the time of 
day to start the backups.

4. Click Update, and then click Backup Now to test the connection to the PC and verify the 
backup is successful. 

3.3 Initiate a Backup
1. Log in to the Allworx administration web page. Navigate to Maintenance > Backup.

2. Click Backup Now. A confirmation box displays. Click OK.

Within a few seconds, a progress bar displays for the backup in the OfficeSafe Administration 
Tool Current Activity window.

3. Wait for the backup to complete, and then click Close to exit the Current Activity window. The 
entries for the Allworx server and this backup display in the left pane of the Administration Tool 
main window.

If doing additional backups on this server, indicate the backup schedule date, time, and 
frequency on the Allworx administration web Backup page.

3.4 Manage the Backup Files
After doing the backups, a tree view of the servers and the backups display in the OfficeSafe 
application main window. The backups display from newest to oldest. Each backup is a complete 
backup set that includes the original full backup and all subsequent incremental backups performed 
prior to the next full backup. 

Selecting either the Server Name or one of the individual backups causes pertinent information display 
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in the Details pane. Drag-and-drop the individual backups to Windows Explorer in order to copy the 
files to different folders. This is useful when transferring a backup to a service PC performing a server 
restore.

A right-click opens a menu with backup management options.

Option Description

Rename Enables changing the server name displayed in the tree and on the Options tabs or renaming the folder that stores 
the current and subsequent backups. The Rename option is only available after selecting a server name.

Delete Removes the server from the tree, all of the backup files, and the server entry from the OfficeSafe database. 
Selecting Delete for an individual backup removes only that backup while leaving the server entry and the other 
backups in the OfficeSafe database.

Options Opens the Options dialog. See “Configuration” on page 8 for more information.
Toll Free 1 866 ALLWORX * 585 421 3850 Page 17
www.allworx.com
Revised: 8/11/15



OfficeSafe Operations Guide Version 8.0
Page 18 Toll Free 1 866 ALLWORX * 585 421 3850
www.allworx.com
Revised: 8/11/15



OfficeSafe Operations Guide Version 8.0
Chapter 4  Restoring Allworx Servers

This chapter describes the steps necessary to restore an Allworx server using an OfficeSafe backup 
file.

4.1 Restore Checklist
Follow the order of the steps for a successful restore. Click the link in the Installation Guide Link 
column for more detailed information. 

4.2 Setting up the Allworx server and the PC

To setup the Allworx server:
1. Disconnect the Allworx server LAN and WAN ports (or the T1 port, if using for the WAN) from 

the customer network.

2. Reboot the Allworx server into SafeMode and connect the PC running the OfficeSafe 
application to the server LAN port.

3. Set up the PC network interface to obtain an IP address via DHCP.

4. Verify that the PC has an IP address on the 192.168.2.x network. Release and renew the IP 
address, if necessary.

a. Click Start and type cmd in the Search field. A command window opens.

Note: Do not use the OfficeSafe 6 or later application to restore backups made using OfficeSafe version 5.x and lower. The 
OfficeSafe 6 or later backups are not compatible with OfficeSafe version 5.x and lower.

Note: If restoring the backup to a new Allworx server, the restore does not install any server feature keys from the original 
server. Obtain the feature keys for the new server from the Allworx distributor.

Step Description Installation Guide Link

1 Setup the Allworx server. For more detailed information, see “To setup the Allworx server:” 
on page 19.

2 Setup the OfficeSafe PC. For more detailed information, see “To setup the OfficeSafe PC:” 
on page 20.

3 Initiate the restore. For more detailed information, see “Initiate the Restore” on 
page 21.

4 Confirm the Allworx server network settings. For more detailed information, see “Confirm the Allworx Server 
Network Settings” on page 21.
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b. Clear the PC current IP settings by typing:

c. Press enter to clear the PC current IP settings.

d. Obtain a new IP Address by typing:

5. Enter the URL to open the Allworx server web administration page.

The SafeMode page displays.

6. Enter the IP address and port number of the OfficeSafe PC in the upper left corner. Find this 
information in the OfficeSafe Administration Tool on the Tools > Options > Network tab. It 
starts with 192.168.2. Do not click Restore yet!

To setup the OfficeSafe PC:
1. Navigate to the OfficeSafe Tools > Options > Network tab. 

2. Verify the IP address 192.168.2.x is present in the Active Network Interfaces list.

3. Navigate to Tools > Options > Restore tab.

4. Select the option that describes which backup to use.

5. Click OK to return to the OfficeSafe main window.

ipconfig /release 

ipconfig /renew

Server URL

Allworx 6x, 6x12, 24x, 48x server http://192.168.2.254:8080

Allworx Connect servers* https://192.168.2.254:8443

* Entering a URL of http://192.168.2.254:8080 redirects to https://192.168.2.254:8443.

Most Recent 
Backup

If the restored server displays in the OfficeSafe Administration Tool server pane, and when using the most 
recent backup for the server.

Named 
Server

If restoring a backup from a different Allworx server stored in the OfficeSafe application on this PC. Verify 
the Allworx server model of the selected server is the same as the restored server. Backups from different 
models of Allworx servers are not compatible.

Select 
Backup File

If the preferred backup is NOT in the server pane of the OfficeSafe Administration Tool main window. This 
option enables selecting an OfficeSafe backup file that is not in the PC OfficeSafe server database.
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4.3 Initiate the Restore

Before starting a restore, disconnect the Allworx server from the customer network and restart it in 
SafeMode. Directly connect a PC to the LAN of the Allworx server. Verify the PC:

• obtains the IP Address automatically.

• preferred backup file is available, either within the OfficeSafe application or elsewhere in the file 
system.

• If the server displays in the server pane of the OfficeSafe Administration Tool main 
window, then the files are available. 

• If the server was backed up using a different PC, copy the backup file onto the PC using 
a USB flash drive or similar device.

1. Log in to the Allworx web administration page. and navigate to Maintenance > Restart.

2. Check the Restart Allworx Server checkbox, and then select Enter Safe Mode after restart.

3. Click Restart Now. Click Continue to confirm the restart.

4. Enter the IP Address of the OfficeSafe PC in the field provided.

5. Click the Restore from OfficeSafe button. When the Allworx server restore is complete, the 
SafeMode page displays Restore Successful in the upper left corner.

6. Select Reboot in Normal Mode, and then click the Reboot button. 

7. Return to the OfficeSafe window. and navigate to View > Current Activity to see the restore 
activity log status. Click the Close button to close the OfficeSafe Current Activity window.

4.4 Confirm the Allworx Server Network Settings
To ensure the restored server network settings are correct, reconnect the Allworx server to the 
customer network, as before.

• If the OfficeSafe PC connections changed to do the restore, return the PC connections and IP 
Address to the original configuration.

• If the restored server is a different server from the backup that was made and if there are 
feature keys for the new server, connect the service PC to the network, open the Server Admin 
page, and install the new feature keys.

Note: Do not use the OfficeSafe 8 application to restore backups from OfficeSafe 5.x or lower.
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